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Running a microCT Scan (for zebrafish) 
 
Part 1: microCT Preparation 

1.​ Turn on the microCT computer (the black console, then the monitor) and start the 

GPUReconServer background server. Then start the SkyScan 1275 program. Check that the 

microCT hard drive is plugged into the USB port on the left side of the monitor. 

2.​ Click the X-Ray icon ☢️ to warm up the scanner. This could take anywhere from 15 minutes to 

over an hour, depending on when the scanner was last used, so plan accordingly. 

 

Part 2: Sample Preparation 
1.​ Refer to PTA Staining Protocol. Samples should be fixed for at least 24 hours in ethanol in the 4°C 

fridge prior to scanning. 

a.​ To fix fish, euthanize them with Tricaine before transferring them to PFA for 1-2 days. 

b.​ Then, replace the PFA with increasing graded concentrations of ethanol, 30%-50%-70% 

for 2 hours each, before placing the fish in 0.7% PTA in 90% methanol for a week. 

c.​ Wash once with ethanol and discard. The fish can be stored in ethanol indefinitely. 

2.​ Select a container that best fits the size of the sample: 

a.​ 1.5 mL Eppendorf tube: 8.0 um resolution 

b.​ 15 mL conical tube: 10.5 um resolution 

c.​ 50 mL conical tube: 35.5 um resolution 

d.​ Gelato jar: 48.5 um resolution 
3.​ Dry the sample thoroughly with Kimwipes and place the sample in purple low-density foam. The 

sample can also be wrapped in Kimwipes. Note the position of the head and tail. 

a.​ If wrapping the sample in Kimwipes: 

i.​  

4.​ Place the sample tail-first into the tube so that when the tube is screwed into the base, the head 

is pointing downwards. 

5.​ Wet the cotton gauze at the bottom of the tube with 1-2 drops of PBS. 

6.​ Cover the top of the test tube (if exposed) with parafilm. 

7.​ Mount the sample onto the imaging stage. Adjust the sample so that the tube is as straight as 

possible. Rotate the stage to check from every angle. 

https://docs.google.com/document/d/14dqkAKPW7wghY-DbnjD7bZj5g8aPmzehqZmVyVWPW68/edit?usp=drive_link
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Part 3: Imaging Preparation 
1.​ Turn off the X-Ray ☢️ when finished warming up. Turn on the X-Ray ☢️ and Grab 📺 functions.  

2.​ Perform a flat-field correction. 

3.​ Type Ctrl + Shift + Alt + S to unlock scanning settings. Go to Options → Scanning Settings and 

adjust as needed, only changing the values in the high resolution column. 

a.​ Generally for zebrafish: 

i.​ 45 kV voltage 

ii.​ 222 uA current 

iii.​ 0.2° rotation step 

4.​ Click “Ok” to save the scanning settings.  

5.​ Double-click ff in the upper left corner to turn flat-field correction off. Turn the X-Ray ☢️ on and 

right-click in the middle of the screen. The average exposure should be between 61-62%. 

6.​ Click “Update flat-field references” and select the first and last boxes. When the computer is 

finished updating, turn flat field correction back on. The average exposure should be between 

90-92%. 

7.​ Turn off the X-Ray ☢️ and open the chamber to place the sample back in.  Turn on the X-Ray 

☢️ and Grab 📺 functions. 

8.​ Move the sample using the up and down arrows, and change the size of the sample by adjusting 

the resolution. 

9.​ Rotate the sample to check for white space (air) on both sides of the tube. The top part of the 

tube will be more affected by any crookedness or wobbling from the base. 

10.​Set the upper and lower bounds of the scan by double-clicking a little above and below the fish. 

11.​Press Start Scan  and a directory for naming the file should show up.  

a.​ The name should include:​  

i.​ A brief description listing any experimental conditions 

ii.​ The date of the scan 

iii.​ The SL of the fish measured from snout to base of tail (if applicable) 

b.​ Example: PracticeScan_4April25_10.5um_45kV_222uA in Tho’s folder 

12.​Click “Make new folder” with the file name, and then click out of the folder onto a random file 

before clicking back in. The folder name should update automatically (the computer is old and 

laggy, so this is a safeguard to make sure the file is named properly). 

13.​Copy-paste the new name into the directory to double-check the file name. 

14.​Check the first four boxes in the Start Scan box. Then, hit Scan to start. 

a.​ Scans can take anywhere from 45 minutes to 2 hours, depending on the size of the fish 

and the region to be scanned (whole body, head only, or tail only).  

b.​ Plan scans accordingly and set a timer to turn off the scanner and remove the sample 

from the chamber. Alternatively, click “Turn computer off after finished scanning. 
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Part 4: Reconstruction 
1.​ Go to File Explorer and select any one of the microCT images from the desired scan. 

2.​ Turn on the NRecon software. The GPUReconServer should run automatically in the background. 

3.​ Go to the Start tab → Preview fastest slice. This selects one representative 2D cross-section 

from the raw scanning data to be processed so you can more quickly see the effects of various 

transformations. 

4.​ Go to View → Show Profile Window, which should show a graph with black and green lines.  

a.​ If the black and green lines match up, no action needed. 

b.​ If the graph is a complete mess, rescan the fish. 

5.​ Perform an X/Y correction. Click Actions → X/Y alignment with reference scan → adjust the box 

to fit the volume of the tube. Click “Match”, wait for the system to finish, then click “Accept”. 

6.​ Click Start → Preview → Output tab and right-click to draw a line bisecting the fish. Then click 

Update Rotation. 

a.​ “X/Y alignment” (misalignment compensation) is a global, uniform shift of the sample’s 

rotation axis relative to the detector. This is needed when there are minor inaccuracies 

in scanner calibration or if the sample was mounted off-center. 

b.​ “Update rotation” addresses a non-uniform misalignment that varies along the Z-axis of 

the sample. This correction is needed when the sample’s rotation axis is not perfectly 

perpendicular to the detector plane (like the Leaning Tower of Pisa), so that features are 

more blurred at the top and/or bottom of the sample. 

i.​ We usually do both corrections for zebrafish samples, but usually only X/Y 

alignment is needed. 

7.​ Go to Start and adjust the green slider to the widest part of the sample.  

a.​ For the posterior (tail) end of zebrafish, this is the section closest to the peduncle.  

b.​ For the anterior (head) end of zebrafish, aim for the ear bones (otoliths), which should 

appear as one or two very dense structures made of calcium carbonate. 

c.​ For samples that have a relatively constant width and density, move the green slider to a 

representative cross-section. 

8.​ Click “Fine Tuning”, select “Post-alignment”, and choose 5 trials with a parameter step of 0.5. 

9.​ Go to Output and resize the blue circle so that it fits inside the tube. You can increase contrast by 

moving the right slider on the histogram inwards. 

a.​ The x-axis on the histogram represents the X-ray attenuation coefficient, how effectively 

a material absorbs or scatters x-rays as they pass through it. Denser materials absorb 

more x-rays and have higher attenuation coefficients, while less dense materials will 

have lower attenuation coefficients. 

b.​ The y-axis represents the number of pixels that have a particular intensity value. 

c.​ Don’t adjust the left slider! 

10.​After resizing the blue circle, move the right slider back to roughly its original position (make 

sure the right slider is completely outside of the black lines).  

11.​Use the left and right sliders at the top of the screen to click back and forth. Select the clearest 

image with the highest resolution, then leave the selected image open on the screen. 
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12.​Return to the Start tab and repeat the Fine Tuning → Post-alignment process for each section.  

13.​When done choosing the clearest slices, adjust the red bounds on the Start tab so that they are 

closer to the top and bottom of the sample, leaving roughly 1-2 cm of buffer. 

14.​On the Start tab, click “Start” to begin the reconstruction process. The reconstruction data will 

be stored in the same folder as the scan data, in a new folder called “ScanTitle_Rec”. 

 

Part 5: 3D Visualization and Analysis 
Introduction 

There are many, many different ways to visualize and analyze the reconstructed results of microCT scans. 

In the past, the lab has used Amira-Avizo software from Thermo-Fisher to create 3D renderings of 

microCT scans – however, technical difficulties accessing the cloud network and slow computer 

processing speeds due to high volumes of data have made using Amira for scans impractical.  

 

The lab owns a Bruker SkyScan 1275 benchtop microCT scanner. The scanner comes with built-in 

software such as NRecon (reconstructs 2D projection images from a microCT scan into 3D volumes), 

DataViewer (allows for slice-by-slice visualization of 3D volumes), CTan (CT-analyzer, useful for density 

and morphological analysis), CTvol (CT-volume, provides surface rendering), and CTvox (provides volume 

rendering). 

 

NOTE: All user manuals and Bruker resources can be found in folders on the microCT computer! Phil 

Salmon’s tutorial videos on YouTube are also incredibly helpful. 

 

  Overview of all software in Bruker MicroCT 3D Suite: what does each program do?

 

Calculating Bone Mineral Density (BMD) on CTan 

 CT-Ananyser ("CTAn") - an overview and introduction.

 Bruker microCT tutorial: Calibration and measurement of bone mineral density (BMD and TMD) in…
1.​ First, open the CTan software. Go to File → Open… → choose the reconstruction file (.bmp) you 

want to import. Make sure Open as Dataset is selected. 

2.​ You should see a Shadow Projection tab showing the 2d projections obtained from the microCT 

scan, a Dataset tab displaying each reconstruction file, and a Cross Section tab displaying the 

reconstructed 3d cross sections.  

3.​ Adjust the slider to the left of the Dataset tab to view different cross-sections.  

4.​ In the upper toolbar, click Regions of interest preview  to set your desired region of interest. 

For example, if scanning a density phantom, adjust the slider until you can see all 5 density 

phantoms in the same cross-section. Then right-click on the sun icon → Set the Top/Bottom 

of Selection to set the upper and lower bounds of the ROI.  

5.​ On the Cross Section tab, either left-click and drag to make a shape, or choose from a list of 

shapes to create the ROI.  

https://www.youtube.com/watch?v=ryvggn1Zih8
https://www.youtube.com/watch?v=3FvmJPJt1gk&t=1640s
https://www.youtube.com/watch?v=l0D4gjwsDI0&t=408s
https://www.bruker.com/en/products-and-solutions/diffractometers-and-x-ray-microscopes/3d-x-ray-microscopes/skyscan-1275.html
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6.​ When creating the ROI, select a range well within the outer borders of the material to avoid 

intermediate areas which may complicate calculations. 

 

 

Round ROI of a density phantom within a selected range. 

 

 

The ROI is well contained within the borders of the material. 

 

7.​ Set an ROI at the upper and lower bounds. The software will automatically generate 

“Interpolated ROIs” to dynamically connect between the endpoints. Double-check the size and 

range of the ROI with the Dataset slider. 

8.​ Go to Binary Selection  → Histogram tab → From dataset to generate binary selections 

using the entire dataset. Toggle VOI view  to make sure the ROI is selected (background 

surrounding the ROI should be green, not black). 

9.​ From here, you can obtain the grayscale indexes, Hounsfield units, attenuation coefficient, and 

bone mineral density for the ROI. To do this, scroll all the way down until you see the Mean 

(total) value. This is the mean value of your metric of interest. 
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