Cytometry Data Analysis in FlowJo V10
Outline – Part I
Intro to FlowJo

• Navigating the V10 Workspace
• Customizing Ribbons
• Demo Data Background
• Creating and Editing Groups
• Graphs, Gating and Ancestry
• The Layout Editor
• Batching and Exporting Graphics
• The Table Editor
The FlowJo v10 Workspace

• A graphical interface to organize your data.

Ribbon
Tabs and Bands

Groups and Group Analysis

Samples and sample analysis
Ribbons, Tabs and Bands

- Ribbon organization allows easy visual navigation of workspace functions.
- Tabs group similar Bands together.
- Bands group similar Actions together.
Customizing Ribbons

• Click on the Ribbon icon to configure

1.

• Drag the icon for any Band into the Ribbon → set of Actions added to your selected Tab.

2.
Importing Data

Three possible methods:
1. Drag and drop into samples pane
2. Click Add Samples button
3. Press ⌘ ;
Todays Demo Data Set: Phospho-Flow + Intracellular Cytokine Staining (PFICS)

Polyclonal PFICS Assay:

- Thaw and rest cryopreserved human PBMC overnight
- Stimulate with PMA+Ionomycin (PI) for 2 hours or rest (NS) while blocking protein secretion → signaling and cytokines
- Stain for viability (AARD) and surface antigens (CD3, CD4, CD8, CD38 and HLA-DR)
- Stimulate PI for 20 minutes or NS rest
- Fix, perm and stain for intracellular antigens (phopho-ERK1/2, IFN-γ and Perforin)
# PFICS Stim Conditions

- 2 Stims → 4 potential combinations

<table>
<thead>
<tr>
<th>Condition</th>
<th>Total Stim Time</th>
<th>phospho-ERK Response</th>
<th>IFN-γ Response</th>
</tr>
</thead>
<tbody>
<tr>
<td>NS+NS</td>
<td>0 min</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>NS+PI</td>
<td>20 min</td>
<td>++++</td>
<td>-</td>
</tr>
<tr>
<td>PI+NS</td>
<td>120 min</td>
<td>+++</td>
<td>+++</td>
</tr>
<tr>
<td>PI+PI</td>
<td>140 min</td>
<td>+++</td>
<td>+++</td>
</tr>
</tbody>
</table>

- 5 donors × 4 stim conditions = 20 experimental All Stain samples
- 1 donor with Fluorescence Minus One (FMO) controls
  7 × 2 stim conditions = 14 FMOs

- 12 Compensation controls
Group Pane

- The Group area lists all groups in the Workspace, # of samples in each group (Size), and the Role of that group (ex. Test, Compensation, Controls).
- Groups act like folders to organize your samples, allows master gating and unique report generation.

- Group owned analysis gains the group color.
Creating and Editing Groups

• To create a new group type ⌘ G, or click the Create Group Icon located in either the task bar at the top of the workspace, or within the Navigate band.

• Double click on an existing group to edit its properties.
Sample Inclusion Criteria

- Live groups automatically include samples based on user-defined inclusion criteria.

- Criteria could include the staining panel, a keyword, characters in the file name, or any combination of these features.
Samples and Sample Analysis

- Displays the sample list and associated analysis of the currently selected group.
- Statistic and #Cells columns are displayed by default. Additional information can be displayed as columns. (Workspace Tab → Add Keywords or Configure Tab → Edit Columns)

<table>
<thead>
<tr>
<th>Name</th>
<th>Statistic</th>
<th>#Cells</th>
<th>*HIV Status</th>
<th>*PID</th>
<th>*STIM</th>
</tr>
</thead>
<tbody>
<tr>
<td>LD1_NS+NS_A01.fcs</td>
<td></td>
<td>250342</td>
<td>Neg</td>
<td>LD1</td>
<td>NS+NS</td>
</tr>
<tr>
<td>LD1_NS+PI_C01.fcs</td>
<td></td>
<td>229585</td>
<td>Neg</td>
<td>LD1</td>
<td>NS+PI</td>
</tr>
<tr>
<td>LD1_PI+NS_B01.fcs</td>
<td></td>
<td>262774</td>
<td>Neg</td>
<td>LD1</td>
<td>PI+NS</td>
</tr>
</tbody>
</table>

- Double click on a sample to open a Graph Window and add gates.
The Graph Window

• Facilitates data visualization and gating.

• Several different plot types are available to display flow data.

• Click on the Options Menu below the graph image and select Graph Type from the dropdown menu.
Gating tools

- Are located at the top left in a Graph Window.

- Gates can always be modified or removed, so don’t be shy.

- Explore the gating options and pick what works best for you.
Graph Display Options

- Try them all and pick what pleases you, or best represents your data.
Transforming Data

- Your data may initially look ‘squished’.
- Click the Transformation [ T ] button and Select Customize Axis… to change the visual display.
Transform Options

1. Select parameter(s)
2. Add or remove extra Pos. decades/range on top end
3. Select scale (Biex displays linear around zero and log further out)
4. Add or remove extra Neg. decades/range on bottom end
5. Width basis scales how much visual display is given to linear vs. log range of the Biex scale
6. Click the Apply button at bottom right to apply the transformation settings to selected parameters
**Effects of Transformation**

**Effects:**
1. Gets rid of the “squishing” of cells.
2. Ensures the visual population center better correlates with the statistical center (median).
3. Make high resolution compensated digital cytometry data more appealing to the eye.
Boolean Combination Gates

- Calculate all possible combinations based on single marker gates (#combinations = $2^{\#\text{gates}}$).
The Layout Editor

- A tool for creating graphical reports.
- Type ⌘ L, or click on the Layout Editor icon.
- Drag populations from a sample to Layout Editor.
Working in Layout Editor

- Similar to the Workspace. Layout Editor has its own customizable Ribbon with Tabs and Bands to organize actions.

- Try clicking on the different tabs to see what types of actions are available.
Within Layout Editor

• Graphs can be organized and re-formatted.
• Statistics, keywords, text and even shapes or objects can be added to illustrate your analysis.

- Right Click on a graph plot for Ancestry and Backgating options
- Right click and select Properties for additional graph formatting
Working in Layout Editor

- Double Click a graph to change its properties/formatting with 4 tabs of Graph Definition options.

[Diagram showing the Graph Definition window with tabs and options highlighted.]
Batch Analysis of Layout Editor

- Batch operations perform repetitive analysis on multiple samples, applying the layout to an entire set of samples.
- Specify Group, Iterate by, Report type and Location, then Click Create Batch Report.
Batch Report Layouts

- Specify Group
- Choose Iterate by option
  - Sample
  - Panel
  - Keyword
    - Iterate By (must be Same for all samples displayed in layout)
    - Discriminator (must be Different for all samples displayed in layout)

- Specify type of Report
- Specify Location to write report
- Click Create Batch Report
The Table Editor

- A tool for creating statistical reports.
- Type ⌘ T, or click on the Table Editor icon.
- Drag Populations & Statistics to Table Editor.
Within Table Editor

- Again, the Table Editor has its own customizable Ribbon with Tabs and Bands to organize actions.

- Specify the group you wish to batch, and how to iterate the batch process, then in the Output band, specify where you want the batch output to go.
Table Editor Visualize Tools

- Table formatting/visualization options such as heat mapping are contained within the Visualize Tab.

- Highlight row(s), then select the visualization.

- Expected Ranges can be set within Preferences

→ Ranges
Table Editor Output

- Formatting/visualization options are maintained when a table is batched to either Display or HTML formats.

- Other file types (ex. Text, CSV, Excel) produce statistics tables lacking visualization formatting.
Outline – Part II
Advanced Tools and Platforms

- Compensation
- Export/Concatenate
- Cell Cycle Analysis
- The Plate Editor
- Plugins – Downsample & tSNE
- Templates
- Additional Training Resources
Compensation

• Compensation corrects for spillover between fluorochrome emission spectra.

• Compensation is essential for multicolor panels
Three Rules of Compensation

• First, there must be a single stained control for every parameter in the experiment!

• In Addition, there are three rules for ‘good’ compensation controls.

1. Controls need to be at least as bright or brighter than any sample the compensation will be applied to.

2. Background fluorescence should be the same for the positive and negative control.

3. Compensation controls MUST match the exact experimental fluorochrome.
PFICS Compensation Controls

- **PBMC Cells**
  1. Unstained Cells
  2. AARD
  3. CD3 Alexa700

- **Compensation Beads**
  1. Unstained Beads with Fix and Perm
  2. CD4 PE-TexasRed
  3. CD8 Pacific Blue
  4. CD38 PE-Cy5
  5. HLA-DR APC-H7
  6. Unstained Beads without Fix and Perm
  7. p-ERK1/2 Alexa 488
  8. IFN-g PE-Cy7
  9. Perforin PE
Compensation

- Select a Compensation Group in the groups window, then click in the task bar.

1. Highlight Compensation Group

2. Click the Compensation Tool

The wizard auto gates samples
Compensation

• Then fills in the positive and negative.

• Choose from the dropdown lists for each parameter.

• Double click preview graphs to modify gates.
Note that you can always create your own gates on a sample and then choose those from the drop down menus.

When set up is complete, select View Matrix (top right) to Modify, Apply, Save or Preview the matrix you’ve created.
Effect of Compensation

Uncompensated

Compensated
Export and Concatenate

- Add and embed keyword metadata
- Merge data from multiple files
- Identify specific populations
- Isolate events for further computational analysis
- Titrate reagents for optimal staining and stimulation conditions
- Visualize responses
Export or Concatenate Data

- The Data Export/Concatenate… action button is located by default in the Document band within the workspace File tab.
- Choose from two options in the drop down menu:
  1) Export/Concatenate Populations
     - subset of events defined by gating hierarchy/phenotype
  2) Export/Concatenate Group
     - all or a subset of events independent of phenotype
Exporting Groups

- Highlight a group containing the samples you wish to export
- Then, choose Export/Concatenate Group (hotkey = shift+⌘+X)
- The Group Export or Concatenate dialog window will appear
Export Options

• **Output panel**
  - Format – selects file format (FCS3 or CSV)
  - Destination – specifies directory where output files will be saved
  - File name example – displays example of naming scheme as specified in Advanced Options → File Naming

• **Include Events panel** – Include all events or down-sample randomly with Include no more than #

• **Parameters panel** – Choose All uncompensated, All compensated, or a custom set of parameters for export

• **Advanced Options File naming panel**
  - Prefix – specifies a common prefix to add
  - Body – specifies the keywords to create a unique name for each file
  - Pattern – displays keyword pattern for body naming scheme
  - Suffix – specifies a suffix to add

• **Status panel**
  - Tells how many files will be produced
Custom File Naming

• Specific options for Export function
• Allows unique keyword pattern to be defined as a distinct naming scheme between exported files.

• **Add a Keyword value**
  Will add an additional keyword value option

• **To change a Keyword value**
  Select from the drop down keyword list

• **To remove a Keyword value**
  Click the red X button
Concatenating Groups

- Highlight a *group* containing the samples you wish to export
- Then, choose Export/Concatenate Group and click the Concatenate button at the top of the dialog

- **Group Concatenation panel**
  - Concatenate all files together
  - Concatenate every “n” files together
  - Concatenate files with equal keyword values

- **Additional Parameters panel**
  - Tells how many files will be produced
Concatenating Populations

- Highlight the equivalent population nodes within the gating tree of samples you wish to merge
- Choose Export/Concatenate Populations
Additional Parameters

• You can select one or more keywords to create new parameters in the concatenated output file.

• Note however, that you will always get a new parameter called Sample ID in the concatenated file. Selecting Sample ID allows you to see the different samples contributing to the concatenated file.
Cell Cycle Analysis

- The Cell Cycle platform allows 1D modeling of cell cycle phases based on DNA content.

- V10.1 has 1D Watson and Dean-Jett-Fox models.
The Plate Editor

• Viewer to add keywords in a plate format

• Located in the visualizations Band within the Tools Tab

• Add new keyword/value pairs to the right. Drag and drop on selected wells.
Plate Visualizations
Plugins

- Java programs that extend the functionality of FlowJo.
- Access from the Plugins menu
  Workspace → Populations band → Plugins menu
Workspace Templates

• Allows saving all analysis reports in your workspace without data.
• Streamlines repetitive analysis of multiple runs using the same staining panel(s).
• File Tab → Document Band → Export Workspace As… Save as a Template
FlowJo Enterprise

- Is a server-based version of FlowJo v10, designed to assist with data archiving, analysis, and report generation for high dimension, high throughput flow or mass cytometry data.
- Can handle data upload directly from the cytometer, store it on a secure server, and provide computational power and automated analysis features for scientists.
- Is an optional add-on component of the FlowJo Licensing Server (FLS) institutional site license.
- Is offered as 1 of 4 tiered packages, with each tier introducing additional features and levels of service.
FlowJo Enterprise Components

Email: enterprise@flowjo.com for information
Additional Training Resources

• Webinars on basic and advanced features of FlowJo, held on the 1st and 3rd Thursday of each month.
• Webinar Schedule can be found at http://www.flowjo.com/webinars/
• Technical Documentation for V10 can be found at http://docs.flowjo.com/
• The Daily Dongle provides tips, tricks and answers to common questions. http://flowjo.typepad.com/
Questions?

• FlowJo is here to help with all your cytometry analysis needs.

• Contact techsupport@flowjo.com for general questions and support.

• Contact timc@flowjo.com for science questions, additional training resources and information on FlowJo Enterprise.

Thank You!